On your mobile device, click on your profile option (should be bottom right inside the app) - on that screen you should have the option to change the map application from Waze Maps to Google Maps to fix this issue.

Did this answer your question?